Running an object opens a new session

I was using Dynamics NAV 2013 R2 stock version and i’ve installed the cumulative update 6 for Dynamics NAV 2013 R2. After that, when I try to run an object in the Development Environment, a new Dynamics NAV session is opened instead of running the object in the currently opened session.

This happens because in order for the client to use the existing client instance it needs to find a client process with the same COM Interface. So you must update the COM interface entries in the registry.

To resolve this problem, after copying the cumulative update files, you have to do the following additional steps:

1. Open the Command Prompt as an administrator

2. Run the RegAsm.exe /register Microsoft.Dynamics.Nav.Client.WinForms.dll /tlb command

C:\Windows\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe /register “C:\Program Files (x86)\Microsoft Dynamics NAV\71\RoleTailored Client\Microsoft.Dynamics.Nav.Client.WinForms.dll” /tlb

After this, the registry entries are updated and the problem is resolved.

UPDATE:

If you’re experiencing the following error:

RegAsm : error RA0000 : The given path’s format is not supported.

That’s is because you’re copying and pasting my example and the inverted commas are invalid. In the command prompt, after pasting, try to delete the inverted commas and write them again. That’s it!

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload the CAPTCHA.

This site uses Akismet to reduce spam. Learn how your comment data is processed.